Start a new topic
Answered

I cannot Print from the the New Studio

I cannot Print from the the New Studio.  I have tried everything The studio shows my printer and that it is ready.  I push print and it tells me it has successfully been queued but then nothing happens. I did all the steps on all their website for trouble shooting and still not able to print  Can anyone help me???? I have already missed deadlines and missing more . I am so frustrated



Best Answer

Kimmiemaedesigns The first thing I would check is that you have the exact same credentials for both Creative Studio and Sawgrass Print Manager. Try the following steps and let me know if that helps at all.


Log out of Sawgrass Print Manager from the Print Manager window https://supportdesk.sawgrassink.com/en/support/solutions/articles/65000151136-print-manager-menu-printer-utilities

Log out of Creative Studio

Clear your cookies a cache

Log back into Sawgrass Print Manager and Creative Studio using the exact same credentials.

Try using a different web browser


4 people have this question

To clarify, the printing issue that you are all likely experiencing comes from a compatibility issue in both Windows and Mac due to recent OS updates. 


We have created a new version of the Sawgrass Print Manager that corrects this issue. It can be downloaded under the Download option here:  https://www.sawgrassink.com/support/vpm 


If you are using the new beta and have not yet opened a support ticket, please do. Our support team is more than happy to help get this up and running as quickly as we can. 


If you have already submitted a ticket, please include your ticket number in your reply so I may pull it and escalate it accordingly. 

Je n'arrive pas à imprimer non plus, je suis dépitée. Les clients attendent et je ne sais que faire...

J'ai installé le SPM pour Mac comme demandé et ça ne change rien.

Quelqu'un a-t-il finalement réussi ou a la solution? Je désespère 

plus possbile de d'imprimer, ainsi ue d'extraire le fichier en format en SGZ... ca devient grave là si on ne peut même plus sortir plusieurs fichiers sur la même page...


Faites quelque chose rapidement s'il vous plait 


I can't print with this new update & how do you change paper size when printing??????  uggggg,  not happy with creative studio right now.  i need help


oh dayssssss... looks like we're in the same boat. Crikey. Why is nothing being done then. 

I can't use the new software as blanks are stuck on loading. When I was able to add a design, the measurements were wrong. Then when I went to print it didn't work. I've opened two support tickets and have received no help. Why did the old software get completely removed when it actually worked?! I have hundreds of orders that aren't fullfilled and deadlines are passing. The customer service for this company has been completely been removed. Small businesses are their lifeline and they're completely ignoring everyone. This is unacceptable! No live chat, no help. 

I can now print with the Beta download but it takes time to load. The sizes are wrong on templates and so many templates that I use are not in the new version.  I had a ticket and support call scheduled  with confirmation for Monday and no one from support ever called.  Sad...sad...sad...


1 person likes this

Do you all have support ticket numbers? As I noted in the pinned post, if you can include them in your response, I will be happy to get them pulled for assistance. 

I have a mac and i had the same problems. This has been discussed before in this thread but i will add a little more. I upgraded my mac os to the latest version of Catalina 10.15.6 from High Sierra 10.13.6. I already downloaded the correct Creative Studio which is linked in a post in this tread. You  can find helpful articles under support. The first is MacOS 10.15 Catalina or later installation and the second is Mac: How to print using SPM. For me this worked and i now can print  outstanding transfers. I can print directly from Creative Studio, i am not using any of their templates. Creative Studio is in black and white and not 3D. Very old looking and basic, but i works for my simple transfers. The only issue i have is my old Epson scanner is not recognized by my Mac anymore because of the os upgrade. I have downloaded all new drivers... from Epson but still no luck. 

Having many problems with this new program! Very frustrated!

 Can't print some of the times, Bought signage and it is not in the blanks; along with other items.

Don't understand why the products of the old program were not put on the new one; along with all the designs from the old program. 

The old program was user friendly  for sizing and moving objects around to include the designs provided.

If this was the program I started with I would have returned everything !

Unhappy customer!


We understand your frustration and want to help, Plpembrd3 I created support ticket  103678  for you.

I've had an open ticket and have requested to have a return call several times. So please don't pretend that you are all here to help us.....

1 person likes this

kvh  I see we have an open ticket for you #103777. Please check your email 

Ok I am ready to call the BBB. I have tried calling Sawgrass everyday, tried scheduling a tech call back, tried emailing out of utter frustration I just found these forums.  How can you expect us to hold our business hostage to this unresponsive company.  This is just an awful experience.

SAME HERE! So very frustrating and a complete waste of time. 


1 person likes this
Login to post a comment